Buck-Boost Converter problems

Support Communities Switchmode Power Supply Buck-Boost Converter problems

This topic contains 3 replies, has 2 voices, and was last updated by  Albert Dunford 2 years, 6 months ago.

  • Author
    Posts
  • #32006

    Declan Doe
    Participant

    Hi,

    I cant seem to get my buck-boost simulation to work. I have calculated the duty cycle correctly I believe at 0.63 for an input of 2.9V and an output of 5V.

    Would someone mind having a look.

    Thanks in advance

    Attachments:
    You must be logged in to view attached files.
  • #32015

    Albert Dunford
    Participant

    There are several issues with your circuit, modifications attached.

    1) you’ve used a 3 level MOSFET, this device requires a proper Vgs to switch on properly. I strongly recommend against using these models when you are trying to figure out if your topology is working. In your circuit I have swapped the 3 level FET with an ideal switch, once this work you can swap to more detailed switch models.

    2) Time to steady state, time step and simulation clock. You need to place the simulation control in circuit. Simulate>simulation control. this is the clock element. You need to ensure that your time step is small enough (at least 20 points per cycle) and that you run the simulation long enough to hit steady state.

    3) input voltage. your input voltage is initially 4.2 V you need to change this to be 2.9V

    Please have a look at our tutorial videos to help you understand how to use the more advanced switch models.
    https://powersimtech.com/support/resources/video-library/

    Attachments:
    You must be logged in to view attached files.
  • #32042

    Declan Doe
    Participant

    Hi Albert, thanks for the help.

    How would I get the level 3 mosfet to work? I tried a 20V input put that did. I don’t understand what I am missing in order to make the mosfet work. I need a level 3 mosfet to simulation a IC I am working on.

    Can you point me to a particular video or something that will better help me understand the problem I’m failing to understand.

    Thanks

  • #32064

    Albert Dunford
    Participant

    try this one:

    https://powersimtech.com/support/resources/video-library/introduction-to-psim-level-2-mosfet-comparison-with-spice/

    the parameters that you use to define the model with are very important for switching at 1.4Mhz. using these models are an unneeded complication if you are simply ensuring your converter works properly

You must be logged in to reply to this topic.